#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z"
Local $sString = "|Groupname|" & @CRLF & _
"" & @CRLF & _
"|---------|" & @CRLF & _
"" & @CRLF & _
"|Agile Transformation (FGH)|" & @CRLF & _
"" & @CRLF & _
"|Innovation Lab|" & @CRLF & _
"from the raw data below using regex" & @CRLF & _
"" & @CRLF & _
"|Groupname|" & @CRLF & _
"" & @CRLF & _
"|---------|" & @CRLF & _
"" & @CRLF & _
"|Agile Transformation (FGH) (10000)|" & @CRLF & _
"" & @CRLF & _
"|Innovation Lab (10001)|" & @CRLF & _
"azeaze" & @CRLF & _
"" & @CRLF & _
"aze"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")