const regex = /\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|(?<title>[^|\\n]+)\\|(?!(.|\\n)*\\|.*\\|(.|\\n)*)\\n?(?<content>(?:.|\\n)+)\\Z', 'm')
const str = `|Groupname|
|---------|
|Agile Transformation (FGH)|
|Innovation Lab|
from the raw data below using regex
|Groupname|
|---------|
|Agile Transformation (FGH) (10000)|
|Innovation Lab (10001)|
azeaze
aze`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}