$re = '/\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z/m';
$str = '|Groupname|
|---------|
|Agile Transformation (FGH)|
|Innovation Lab|
from the raw data below using regex
|Groupname|
|---------|
|Agile Transformation (FGH) (10000)|
|Innovation Lab (10001)|
azeaze
aze';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);