using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z";
string input = @"|Groupname|
|---------|
|Agile Transformation (FGH)|
|Innovation Lab|
from the raw data below using regex
|Groupname|
|---------|
|Agile Transformation (FGH) (10000)|
|Innovation Lab (10001)|
azeaze
aze";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}