import Foundation
let pattern = #"\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|Groupname|
|---------|
|Agile Transformation (FGH)|
|Innovation Lab|
from the raw data below using regex
|Groupname|
|---------|
|Agile Transformation (FGH) (10000)|
|Innovation Lab (10001)|
azeaze
aze
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}