# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\|(?<title>[^|\n]+)\|(?!(.|\n)*\|.*\|(.|\n)*)\n?(?<content>(?:.|\n)+)\Z"
test_str = ("|Groupname|\n\n"
"|---------|\n\n"
"|Agile Transformation (FGH)|\n\n"
"|Innovation Lab|\n"
"from the raw data below using regex\n\n"
"|Groupname|\n\n"
"|---------|\n\n"
"|Agile Transformation (FGH) (10000)|\n\n"
"|Innovation Lab (10001)|\n"
"azeaze\n\n"
"aze")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.