#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)"
Local $sString = "" & @CRLF & _
"company name" & @CRLF & _
"Order XXX395411" & @CRLF & _
"Your order is on the way" & @CRLF & _
"Your order is on the way. Track your shipment to see the delivery status." & @CRLF & _
"" & @CRLF & _
"View your order" & @CRLF & _
"or Visit our store" & @CRLF & _
"Items in this shipment" & @CRLF & _
" X X - X X X X X X X × 1" & @CRLF & _
"X" & @CRLF & _
" X" & @CRLF & _
"Customer Information" & @CRLF & _
"X" & @CRLF & _
"" & @CRLF & _
"Shipping Address" & @CRLF & _
"FIRST LAST" & @CRLF & _
"" & @CRLF & _
"1000 ANY STREET" & @CRLF & _
"" & @CRLF & _
"CITY/STATE/ZIP" & @CRLF & _
"" & @CRLF & _
"Shipping Method" & @CRLF & _
"Ground Advantage" & @CRLF & _
"" & @CRLF & _
"Shipping Company" & @CRLF & _
"USPS" & @CRLF & _
"" & @CRLF & _
"Tracking Number" & @CRLF & _
"9434650105496020838711" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")