use strict;
my $str = '
company name
Order XXX395411
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order
or Visit our store
Items in this shipment
X X - X X X X X X X × 1
X
X
Customer Information
X
Shipping Address
FIRST LAST
1000 ANY STREET
CITY/STATE/ZIP
Shipping Method
Ground Advantage
Shipping Company
USPS
Tracking Number
9434650105496020838711
';
my $regex = qr/Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}