$re = '/Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)/m';
$str = '
company name
Order XXX395411
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order
or Visit our store
Items in this shipment
X X - X X X X X X X × 1
X
X
Customer Information
X
Shipping Address
FIRST LAST
1000 ANY STREET
CITY/STATE/ZIP
Shipping Method
Ground Advantage
Shipping Company
USPS
Tracking Number
9434650105496020838711
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);