const regex = /Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Shipping Address.*\\n(?<name>.+)\\n+(?<address>.+)\\n+(?<address2>.+)|Tracking Number.*\\n(.+)', 'gm')
const str = `
company name
Order XXX395411
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order
or Visit our store
Items in this shipment
X X - X X X X X X X × 1
X
X
Customer Information
X
Shipping Address
FIRST LAST
1000 ANY STREET
CITY/STATE/ZIP
Shipping Method
Ground Advantage
Shipping Company
USPS
Tracking Number
9434650105496020838711
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}