package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)`)
var str = `
company name
Order XXX395411
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order
or Visit our store
Items in this shipment
X X - X X X X X X X × 1
X
X
Customer Information
X
Shipping Address
FIRST LAST
1000 ANY STREET
CITY/STATE/ZIP
Shipping Method
Ground Advantage
Shipping Company
USPS
Tracking Number
9434650105496020838711
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}