import Foundation
let pattern = #"Shipping Address.*\n(?<name>.+)\n+(?<address>.+)\n+(?<address2>.+)|Tracking Number.*\n(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
company name
Order XXX395411
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order
or Visit our store
Items in this shipment
X X - X X X X X X X × 1
X
X
Customer Information
X
Shipping Address
FIRST LAST
1000 ANY STREET
CITY/STATE/ZIP
Shipping Method
Ground Advantage
Shipping Company
USPS
Tracking Number
9434650105496020838711
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)