#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d-_:|\.]+[\d.]+\|([\w]+)"
Local $sString = "2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")