using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d-_:|\.]+[\d.]+\|([\w]+)";
string input = @"2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}