const regex = /[\d-_:|\.]+[\d.]+\|([\w]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d-_:|\\.]+[\\d.]+\\|([\\w]+)', '')
const str = `2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}