package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d-_:|\.]+[\d.]+\|([\w]+)`)
var str = `2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}