re = /[\d-_:|\.]+[\d.]+\|([\w]+)/
str = '2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6'
# Print the match result
str.match(re) do |match|
puts match.to_s
end