use strict;
my $str = '[02]: ./media/active-directory-dotnet-how-to-use-access-control/acs-01.png';
my $regex = qr/\[|/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";