import Foundation
let pattern = #"\[|"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[02]: ./media/active-directory-dotnet-how-to-use-access-control/acs-01.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)