const regex = /enum[^{]*{\s*((?!([A-Z][_A-Z0-9]+))\w+)(,\s*(?![_A-Z0-9]+)\w+)*(;[^}]*)*\s*}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('enum[^{]*{\\s*((?!([A-Z][_A-Z0-9]+))\\w+)(,\\s*(?![_A-Z0-9]+)\\w+)*(;[^}]*)*\\s*}', '')
const str = `enum TransparencyState {
one
}
enum Blah {
One
}
enum TransparencyState {
gone, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
Gone,
translucent,
opaque
}
enum Blah {
One, TwO_t
}
public enum SearchType {
PARTNO_1,
pART_TYPE;
@Override
public String toString() {
return super.toString();
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}