use strict;
my $str = 'enum TransparencyState {
one
}
enum Blah {
One
}
enum TransparencyState {
gone, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
Gone,
translucent,
opaque
}
enum Blah {
One, TwO_t
}
public enum SearchType {
PARTNO_1,
pART_TYPE;
@Override
public String toString() {
return super.toString();
}
}';
my $regex = qr/enum[^{]*{\s*((?!([A-Z][_A-Z0-9]+))\w+)(,\s*(?![_A-Z0-9]+)\w+)*(;[^}]*)*\s*}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}