import re
regex = re.compile(r"enum[^{]*{\s*((?!([A-Z][_A-Z0-9]+))\w+)(,\s*(?![_A-Z0-9]+)\w+)*(;[^}]*)*\s*}")
test_str = ("enum TransparencyState {\n"
" one\n"
" }\n\n"
"enum Blah {\n"
" One\n"
"}\n\n"
"enum TransparencyState {\n"
" gone, TRANSLUCENT, OPAQUE_OR_DULL\n"
" }\n\n"
"enum TransparencyState {\n"
" Gone, \n"
" translucent, \n"
" opaque\n"
" }\n\n"
"enum Blah {\n"
" One, TwO_t\n"
"}\n\n"
"public enum SearchType {\n"
" PARTNO_1,\n"
" pART_TYPE;\n\n"
" @Override\n"
" public String toString() {\n"
" return super.toString();\n"
" }\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")