import Foundation
let pattern = #"enum[^{]*{\s*((?!([A-Z][_A-Z0-9]+))\w+)(,\s*(?![_A-Z0-9]+)\w+)*(;[^}]*)*\s*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
enum TransparencyState {
one
}
enum Blah {
One
}
enum TransparencyState {
gone, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
Gone,
translucent,
opaque
}
enum Blah {
One, TwO_t
}
public enum SearchType {
PARTNO_1,
pART_TYPE;
@Override
public String toString() {
return super.toString();
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}