re = /enum[^{]*{\s*((?!([A-Z][_A-Z0-9]+))\w+)(,\s*(?![_A-Z0-9]+)\w+)*(;[^}]*)*\s*}/
str = 'enum TransparencyState {
one
}
enum Blah {
One
}
enum TransparencyState {
gone, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
Gone,
translucent,
opaque
}
enum Blah {
One, TwO_t
}
public enum SearchType {
PARTNO_1,
pART_TYPE;
@Override
public String toString() {
return super.toString();
}
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end