# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/textb_(?<number>[0-9]+)/\1/;t' <<< "texta_123,textb_456"