#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "textb_(?<number>[0-9]+)"
Local $sString = "texta_123,textb_456"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)