const regex = /textb_(?<number>[0-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('textb_(?<number>[0-9]+)', '')
const str = `texta_123,textb_456`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);