$re = '/textb_(?<number>[0-9]+)/';
$str = 'texta_123,textb_456';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;