using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"textb_(?<number>[0-9]+)";
string substitution = @"\1";
string input = @"texta_123,textb_456";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}