re = /textb_(?<number>[0-9]+)/
str = 'texta_123,textb_456'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result