import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(?=99)99(\\.0+)?|([1-9]\\d?(\\.\\d+)?))$";
final String string = "1.00\n"
+ "99.00\n"
+ "0.00\n"
+ "1.25\n"
+ "56.9658\n"
+ "99\n"
+ "99.25\n"
+ "99.00\n"
+ "9.36\n"
+ "99.58\n"
+ "5\n"
+ "98.52\n"
+ "90";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}