# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?(?=99)99(\.0+)?|([1-9]\d?(\.\d+)?))$"
test_str = ("1.00\n"
"99.00\n"
"0.00\n"
"1.25\n"
"56.9658\n"
"99\n"
"99.25\n"
"99.00\n"
"9.36\n"
"99.58\n"
"5\n"
"98.52\n"
"90")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.