const regex = /^(?(?=99)99(\.0+)?|([1-9]\d?(\.\d+)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?(?=99)99(\\.0+)?|([1-9]\\d?(\\.\\d+)?))$', 'gm')
const str = `1.00
99.00
0.00
1.25
56.9658
99
99.25
99.00
9.36
99.58
5
98.52
90`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}