use strict;
my $str = '1.00
99.00
0.00
1.25
56.9658
99
99.25
99.00
9.36
99.58
5
98.52
90';
my $regex = qr/^(?(?=99)99(\.0+)?|([1-9]\d?(\.\d+)?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}