#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!.\G")(?<="|\\\\")(?<![^\\]\\")((?>\\.|[^"])*?)(?=")"
Local $sString = ""alice" "bob"" & @CRLF & _
"" & @CRLF & _
""\"alice\"" "\"bob\""" & @CRLF & _
"" & @CRLF & _
""\"""\""" & @CRLF & _
"" & @CRLF & _
"" " " "" & @CRLF & _
"" & @CRLF & _
"Hello "my" name is "Andy", "nice" to meet you." & @CRLF & _
"" & @CRLF & _
"Foo "bar" baz\"\\"qux"." & @CRLF & _
"" & @CRLF & _
"\\"s\"s\\"g""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")