$re = '/(?<!.\G")(?<="|\\\\\\\\")(?<![^\\\\]\\\\")((?>\\\\.|[^"])*?)(?=")/';
$str = '"alice" "bob"
"\\"alice\\"" "\\"bob\\""
"\\"""\\""
" " " "
Hello "my" name is "Andy", "nice" to meet you.
Foo "bar" baz\\"\\\\"qux".
\\\\"s\\"s\\\\"g"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);