using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!.\G"")(?<=""|\\\\"")(?<![^\\]\\"")((?>\\.|[^""])*?)(?="")";
string input = @"""alice"" ""bob""
""\""alice\"" ""\""bob\""
""\""""\""
"" "" "" ""
Hello ""my"" name is ""Andy"", ""nice"" to meet you.
Foo ""bar"" baz\""\\""qux"".
\\""s\""s\\""g""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}