const regex = /(?<!.\G")(?<="|\\\\")(?<![^\\]\\")((?>\\.|[^"])*?)(?=")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!.\\G")(?<="|\\\\\\\\")(?<![^\\\\]\\\\")((?>\\\\.|[^"])*?)(?=")', 'g')
const str = `"alice" "bob"
"\\"alice\\"" "\\"bob\\""
"\\"""\\""
" " " "
Hello "my" name is "Andy", "nice" to meet you.
Foo "bar" baz\\"\\\\"qux".
\\\\"s\\"s\\\\"g"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}