import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!.\\G\")(?<=\"|\\\\\\\\\")(?<![^\\\\]\\\\\")((?>\\\\.|[^\"])*?)(?=\")";
final String string = "\"alice\" \"bob\"\n\n"
+ "\"\\\"alice\\\"\" \"\\\"bob\\\"\"\n\n"
+ "\"\\\"\"\"\\\"\"\n\n"
+ "\" \" \" \"\n\n"
+ "Hello \"my\" name is \"Andy\", \"nice\" to meet you.\n\n"
+ "Foo \"bar\" baz\\\"\\\\\"qux\".\n\n"
+ "\\\\\"s\\\"s\\\\\"g\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}