import re
regex = re.compile(r"(?<!.\G\")(?<=\"|\\\\\")(?<![^\\]\\\")((?>\\.|[^\"])*?)(?=\")")
test_str = ("\"alice\" \"bob\"\n\n"
"\"\\\"alice\\\"\" \"\\\"bob\\\"\"\n\n"
"\"\\\"\"\"\\\"\"\n\n"
"\" \" \" \"\n\n"
"Hello \"my\" name is \"Andy\", \"nice\" to meet you.\n\n"
"Foo \"bar\" baz\\\"\\\\\"qux\".\n\n"
"\\\\\"s\\\"s\\\\\"g\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")