# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\v+(?=To:)/_/g;t' <<< "To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht"