#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\v+(?=To:)"
Local $sString = "To: ab@domain.tld" & @CRLF & _
"Subject: Der Betreff" & @CRLF & _
"From: xp@domain.tld" & @CRLF & _
"Reply-To: xp@domain.tld" & @CRLF & _
"" & @CRLF & _
"Hier kommt meine Nachricht" & @CRLF & _
"" & @CRLF & _
"To: ab@domain.tld" & @CRLF & _
"Subject: Der Betreff" & @CRLF & _
"From: xp@domain.tld" & @CRLF & _
"Reply-To: xp@domain.tld" & @CRLF & _
"" & @CRLF & _
"Hier kommt meine Nachricht" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"To: ab@domain.tld" & @CRLF & _
"Subject: Der Betreff" & @CRLF & _
"From: xp@domain.tld" & @CRLF & _
"Reply-To: xp@domain.tld" & @CRLF & _
"" & @CRLF & _
"Hier kommt meine Nachricht"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)