import Foundation
let pattern = #"\v+(?=To:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)