import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\v+(?=To:)";
final String string = "To: ab@domain.tld\n"
+ "Subject: Der Betreff\n"
+ "From: xp@domain.tld\n"
+ "Reply-To: xp@domain.tld\n\n"
+ "Hier kommt meine Nachricht\n\n"
+ "To: ab@domain.tld\n"
+ "Subject: Der Betreff\n"
+ "From: xp@domain.tld\n"
+ "Reply-To: xp@domain.tld\n\n"
+ "Hier kommt meine Nachricht\n\n\n"
+ "To: ab@domain.tld\n"
+ "Subject: Der Betreff\n"
+ "From: xp@domain.tld\n"
+ "Reply-To: xp@domain.tld\n\n"
+ "Hier kommt meine Nachricht";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}