using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\v+(?=To:)";
string substitution = @"_";
string input = @"To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht
To: ab@domain.tld
Subject: Der Betreff
From: xp@domain.tld
Reply-To: xp@domain.tld
Hier kommt meine Nachricht";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}