using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?=[a-zA-Z\d]{8})[A-Za-z]+\d*)$";
string input = @"abc12345
w1234567
qweqr123
jsgwiuegn1274124
qwerasdf
awdjwuadhuf
wrong examples:
12345678
qwe12qwe
12qweqwe
qweq12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}