re = /^(?:(?=[a-zA-Z\d]{8})[A-Za-z]+\d*)$/m
str = 'abc12345
w1234567
qweqr123
jsgwiuegn1274124
qwerasdf
awdjwuadhuf
wrong examples:
12345678
qwe12qwe
12qweqwe
qweq12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end