import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=[a-zA-Z\\d]{8})[A-Za-z]+\\d*)$";
final String string = "abc12345\n"
+ "w1234567\n"
+ "qweqr123\n"
+ "jsgwiuegn1274124\n"
+ "qwerasdf\n"
+ "awdjwuadhuf\n\n"
+ "wrong examples: \n"
+ "12345678\n"
+ "qwe12qwe\n"
+ "12qweqwe\n"
+ "qweq12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}