const regex = /^(?:(?=[a-zA-Z\d]{8})[A-Za-z]+\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=[a-zA-Z\\d]{8})[A-Za-z]+\\d*)$', 'gm')
const str = `abc12345
w1234567
qweqr123
jsgwiuegn1274124
qwerasdf
awdjwuadhuf
wrong examples:
12345678
qwe12qwe
12qweqwe
qweq12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}