#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?=\s|\)|$)"
Local $sString = "Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)" & @CRLF & _
"Host is up (0.047s latency)." & @CRLF & _
"Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)" & @CRLF & _
"Host is up (0.048s latency)." & @CRLF & _
"Nmap scan report for 192.168.25.2" & @CRLF & _
"Host is up (0.048s latency)." & @CRLF & _
"Nmap scan report for 192.168.25.3" & @CRLF & _
"Host is up (0.048s latency)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")